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1. Introduction 
 

CommNetEG program allows the data reception from LSI LASTEM instruments (E-Log type) to 

PC, according to manual or automatic mode. CommNetEG program manages one or more 

communication channels: parallel type, serial type, PSTN and GPRS modem, radio and LAN. 
 
 

2. System requirements 
 

The program needs following hardware and software requirements: 
 

Personal computer 

 

 Processor with operating frequency of 600 MHz or more, 1 GHz  recommended; 

 Display card: SVGA resolution 1024x768 or more; standard screen resolution (96 dpi). 

 Operating system (*):  

o Microsoft Windows 32 bit XP SP3 (only 32 bit)/Vista/7/2003/8/2008/2010 

 Microsoft .NET Framework V.3.5 (**); 

 Program LSI 3DOM installed; 

 

(*) Operating systems must be updated with the latest update released by Microsoft and 

available through Windows Update; for operating systems not listed is not guaranteed correct 

and complete operation of programs. 

(**)The  Microsoft. NET Framework 3.5 setup is included in the  LSI Lastem product 

 DVD issued after March 2011 and, if necessary, is automatically installed during the installation 

process starts from the DVD. If you do not have the updated version of the DVD you can 

download the installer for the Microsoft. NET Framework 3.5 directly from the Microsoft 

Download Center at  http://www.microsoft.com/downloads/en/default.aspx inserting in the search 

field.  the term ".NET". 

On Windows 8 you can enable. NET Framework 3.5 manually from the  Control Panel . In the 

Control Panel  you can use Add Programs and Features , then  Enable or disable Windows features  

and then select the check box  Microsoft. NET Framework 3.5.1. . This option requires an Internet 

connection. 

 

 

 

Acquisition instruments 

 

Data logger LSI LASTEM E-Log, R-Log. 
 
 

http://www.microsoft.com/downloads/en/default.aspx
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3. Installation 
 

First of all check the needed system requirements. Software installation needs the login with system 

administration rights; at the opposite the installation will be not correct. 

 

Install CommNetEG starting program Setup from CD. The installation program will supply all 

needed instructions  

 
 

3.1. Organization of installed files  
 

The installation sets up some folders; beginning from folder selected during installation  (default 

c:\Programmi\LSI-Lastem\CommNetEG). They are: 

 

 Bin: includes the executing files CommNetEG, CommNetEG Config and the support 

libraries; 

 Doc: includes the program documentation (including user manual). 
 

Other folders are setup in c:\Documents and Settings\All Users\ Application data \LSI-

Lastem\CommNetEG and c:\Documents and Settings\All Users\ Application data \LSI-

Lastem\CommNetEG Config; the operating system usually hides these folders. Display them 

selecting “Show hidden files and folders” from folder’s properties.  

 

New folder in c:\Documents and Settings\[User]\Application data\LSI-Lastem\CommNetEG\Log, 

where [User] corresponds to the name of the user who executed login in the operating system, 

includes the log files of the program CommNetEG. 

 

NOTE 

In Windows Vista and Windows 7 the folder c:\Documents and Settings\All Users\Application 

data is the same as c:\ProgramData. 
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4. Preliminary remarks 
 

The program consists of two separated forms: CommNetEG and CommNetEG Config.  

CommNetEG program executes the calls and the data save; CommNetEG Config program 

configures CommNetEG. 

 

In order to receive the data from LSI LASTEM instruments, CommNetEG needs:  

 

 Licence file for each instrument; 

 Instruments must be configured correctly; 

 Configurations should have been downloaded correctly through 3DOM program.  

 

NOTE 

In order to use LSI LASTEM datalogger, the system needs that: 3DOM has been installed and 

the instrument’s configuration has been already received; only in this way CommNetEG is able 

to use this instrument for calls. 
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5. CommNetEG Config: program 

configuration 
 

The operating modes of CommNetEG may be set up through program CommNetEG Config; it 

allows configuring: 
 

 Data storage and modes (text files, database..); 

 Instruments grouping to facilitate Calls definition; 

 Calls typologies. 

 Instruments grouping to facilitate viewing during communications; 
 

Every different call typology can be associated with several instruments grouping; every 

instruments group is combined with specific configuration of the data storage, in order to allow 

maximum flexibility during use of the program. 

 

These setups are saved into configuration file with extension .cnt. The program allows the setup of 

one or more configuration files, which can be used alternatively, according to particular 

communication needs. 
 

 

5.1. Program’s main components 
 

After start the program shows as follow:  
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On the left side of the main window there’s the Browser, it includes several components of 

configuration that’s being modified: 
 

 The configuration groups of the data supports (Data Storage Groups); 

 The aggregation groups of the instruments (Groups); 

 The calls (Calls) subdivided into Outgoing calls and Incoming calls. 

 The Instruments Views to aggregate instruments to facilitate viewing communications. 

 

On the right side of the main window are displayed the details of the component selected from 

Browser. 

 

5.2. Menus structure 
 

The menu and the keys bar allow the selection of different options available in the program. 

 

Menu File shows following entries:  

 

 New: opens new processing; 

 Open: opens an existing processing; 

 Verify: checks the validity of current processing; 

 Show report …: displays the configuration report; 

 Save: saves the current processing; 

 Save as…: saves the current processing with different name; 

 Recent files: displays the list of the files opened recently; 

 Exit: program exit. 

 

Menu Edit shows following entries: 

 

 Add instruments group configuration …: starts the guided procedure for configuration of an 

instruments group; 

 Add Data Storage: adds a configured list of data storage; it consists of two sub-menus: one 

menu for each type of configurable group: 

o Elaborated Data: for storage of processed data; 

o Other Data: for storage of non-processed data (i.e.: instantaneous data). 

 Remove Data Storage: removes the selected group; 

 Add Group: adds new group of instruments; 

 Remove Group: removes the selected group of instruments; 

 Add Call: adds a call; 

 Remove Call: remove the selected call; 

 Edit elaborated Data date request: modifies the date of first request of processed data, like 

stored into computer. 

 

Menu Tools shows following entries: 

 

 Available Instruments…: displays the list of configured acquisition instruments that can be 

use by CommNetEG; 

 Export Configuration: exports all files used by current configuration into compressed 

archive; 

 Import Configuration: imports from a previously setup archive all files used by given 

configuration. 

 License Manager: starts License Manager Program. 
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Menu Help shows following entries: 

 

 Contents: displays this document; 

 Check for Updates: checks the availability of program updates from LSI LASTEM website; 

 About this Application: displays the information about the application, including the 

program release. 
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5.3. Setup or open new configuration 
 

In order to setup new configuration select menu File -> New or key .  

In order to open an existing configuration select menu File -> Open or menu File -> Recent files or 

key  and select the recommended file. 

 

To make easier the procedure for setup of configuration you can use guided procedure for 

configuration of instruments single group (§ 5.9) 

 

WARNING 

When new configuration is setup, the program adds automatically a Data Storage Group for 

elaborated data (§ 5.5 ) with the current configuration used by 3DOM program. 

 

 

5.4. Save the configuration 
 

In order to save the current configuration on the same file, from which it has been loaded, select  

menu File -> Save or key . To save the current configuration on new file, select menu File -> 

Save as.... 

 

 

5.5. Configuration of General Options 
 

In order to configure the general options of configuration select item General Options from 

browser. In this way you can modify the name of configuration (displayed in the main item of 

browser), the clocks synchronization options and the options for entry calls. 

 

 
 

In particular specify TCP listening port and used network card in order to configure the entry calls. 
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5.6. Configuration of Data Storage Groups 
 

To configure a Data Storage Group select it from browser; to setup a new one select menu Edit -> 

Add Data Storage -> Elaborated Data or Other data. 

 

Data Storage Groups are divided into two typologies: 

 

 Elaborated Data; 

 Other data (for instantaneous data, state data, etc.). 

 

This sharing is made because some data storage supports aren’t able to save the data in case they 

aren’t type Elaborated Data; for example the database used by InfoGAP is able to store only 

elaborated statistic data, and for this reason it doesn’t support the storage of instantaneous data. 

 

Every Data Storage Group can contain the configuration of all data storage which are available in 

the installation for selected datum (elaborated or other type). 

 

 

 

 
 

 

For every Data Storage Group can be specified: 

 

 The group’s ID name; 

 The list of configured data storage. 

 

To add, modify or remove one data storage from list use keys <Add>, <Edit> and <Remove>. 

 

WARNING 

Every “Data Storage Group” must contain one configured data storage at last, and it cannot 

contain two different configurations of the same data storage. 
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5.6.1. Add or modify one data storage  

 

To add one data storage press key <Add>, to modify the selected data storage press key <Edit>. In 

mask Data Storage Configuration select the desired data storage and press key <Continue> to 

activate the configuration mask of selected data storage.  

 

 
 

 

The current program release has got three possible data save modes:  

 

1. TextFile: storage of text files in ASCII format; 

2. InfoGap: storage into database, which can be used by InfoGAP program for display of 

downloaded data. This data storage can save only elaborated data. 

3. Gidas: storage into Gidas database (SQL Server 2005) that can be used by GidasViewer. 

 

WARNING 

The mask will display only data storage that can be configured for datum type which the 

configuration is referred to (elaborated data of other type). 

 

5.6.1.1. TextFile: storage the data into text file  

 

The storage in text files allows the save of the elaborated data, instantaneous data and instrument’s 

statistics. 

 

Here below is the mask that configures the storage of text file: 
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Format options, it’s possible set-up: 

 

 Decimal numbers separator (to display the real numbers); 

 Decimal places for each processed number; 

 Number of characters to display each number; 

 Data columns separator, (select it from the list or input a new one); 

 Date time format: it is possible to select one of these options: 

a. Local: uses computer local settings; 

b. ISO 8601: uses ISO 8601 format (year-month-dayThours:minutes:seconds); 

c. Year/Month/Day, Month/Day/Year, Day/Month/Year: uses this sort order to format 

date; to format time always uses local separator; 

d. Custom: user can insert a custom format using these characters: yyyy=year, 

MM=month, dd=day, HH=hour, mm=minutes, ss=seconds 

 

General options, it’s possible to set-up: 
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 The mode for the display of the file header; selecting the checkbox Store informative 

headers it inputs the header inside the data file (this header describes the structure of the 

available measures and processings 

 The writing mode on file: selecting Append data on the same file every download writes the 

data at the end (queue) of the file; ); if this option is enabled you can also select the option 

Create new file every day to create e new file every day. 

WARNING: the date used to decide if it is necessary to create a new file is the download 

date and not the elaborated values date.  

 

Folder options, it’s possible set-up: 

 

 The main folder where save the files; 

 Select Append serial number, to save the files in different folders adding serial number to 

the main folder, select Append user name, to save the files in different folders adding 

instrument user name to the main folder, 

 

File options, to generate the name of the file where downloaded values are saved select the button 

 to open the Definition of the file name windows; 

 

 
 

In this window you can specify the file extension and build the file name using a series of TAG to 

dynamically generate it. The available TAGS are: 

 

 %SN% : this TAG inserts in the name of the file the serial number of the datalogger 

 %UN% : this TAG inserts in the name of the file the user defined name of the datalogger 

 %FT% : this TAG inserts in the name of the file the type of the downloaded data (values are 

Elab for elaborated values, Inst for instantaneous values, Status for statistical values) 
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 %YMD%, %MDY%, %DMY% : these TAGS insert in the name of the file the file creation 

date using four digits to represent year and two digits to represent month and day. The 

difference between these TAGS are elements order (Y=year, M=month, D=day) 

 %HMS% : this TAG inserts in the name of the file the file creation time using the format 

hours (from 00 to 23) minutes (from 00 to 59) seconds (from 00 to 59). 

 %CFG%; this TAG inserts in the name of the file the configuration date of the datalogger in 

the format yyyyMMddHHmmss. 

 

 

Every TAG is begins and ends with the characters “%” and is case sensitive. The red label shows 

the resulting file name assuming an instrument with Serial Number=12345678 and a User Name = 

meteo1. 

 

Warning 

If the user doesn’t select the option “Append data on the same file” every instrument data save 

sets-up one new data file .  

If the user selects the option “Append data on the same file”, the name of the file should NOT  

include date or time TAGS; if the user selects the option “Append data on the same file” AND the 

option “Create a new file every day” the name of the file MUST contain a date TAG and should 

NOT contain a time TAG. 

 

Example of: Save of one instantaneous data record: 

 
UpdateTime=2007-12-18T14:54:00 

SerialNr=06040062 

Ch1 VELVento=0 m/s 

Ch2 TempINTerna=23.2 'C 

Ch3 LivBATTeria=80 % 

Ch4 SOILTemp=-55.8 'C 

 

Example of: Save of one processed data record: 

 
Date/hours Wind-Speed (m/s) Msr.1 Inp.9   

    Min Ave Max 

2007-12-18T14:20:00 0.80 1.00 1.20 

2007-12-18T14:30:00 0.80 1.00 1.20  

 

 

Example of: Save of one statistic data record: 

 
SerialNr=05110008 

InstrumentDate=2008-04-03T11:56:58 

LivingTime=29.17:56:34 

StatisticTime=29.17:56:34 

RunMode=Normal 

 

SerialPort=1 

ReceivedBytes=38687846 

SentBytes=14169993 

TotalReceivedFrames=190256 

ReceivedBadFrames=2 

SentFrames=190210 
 

 

5.6.1.2. InfoGap: Storage data into InfoGAP database 

 

The storage on InfoGAP database allows the save of elaborated data only.  
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Following mask configures the storage on InfoGAP database: 

 

 
 

It’s possible to set up following options: 

 

 Autogenerate survey: it generates new survey at every download; if the checkbox hasn’t 

been selected the program generates new survey only at first download, and queues the data 

downloaded successively. If anyone of instrument’s configuration parameter has been 

modified, a new survey will be generate at time of new data download; 

 Archive InfoGAP: select InfoGAP database for data save; this database is usually inside the 

folder Database of InfoGAP’s installation and it’s called InfoGenStor.mdb. 

 

Press key Ok to accept the modifications. 

 

WARNING 

The storage of data on InfoGAP database needs: 

 

 InfoGAP software must have been installed; 

 Instrument’s configuration must be compatible with InfoGAP 

 InfoGAP database must have up-to-dated operative codes tables, and it must be updated to 

version 2.0.7 or higher; 

 The instrument from which data are downloaded must have been inputted and enabled 

into database using InfoGAP software. 

 

5.6.1.3. Gidas: Storage data into Gidas database 

Gidas database allows the storage of processed data and instantaneous data. 

 

Here below you can find the window for storage in Gidas database: 
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You can setup these options: 

 

 Instance of SQL Server: select SQL Server 2005 instance that includes Gidas database (use 

point like default instance in local computer; use .\SQLEXPRESS like default instance of 

SQL Server 2005). 

 

 Windows authentication use: in case of use of Windows authentication the current user 

needs the privileges for connection to SQL Server 2005 instance and use of Gidas database; 

at the opposite it’ll use the users set by program for database installation and the access to 

SQL Server 2005 instance happens through mixed mode. 

 

 

 

WARNING 

In order to store the data into Gidas database of SQL Server 2005 you need Gidasviewer 

program, which installs database and needs one activation licence for each instrument. Gidas 

database needs SQL Server 2005: if user doesn’t have it, the free release Express SQL Server 

2005 will be installed during database installation. 

For further information make reference to handbook of GidasViewer program. 

 

5.6.1.4. XPanelFile: storage data to use as sources for XPanel program 

 

Xpanel is the system for the dynamic visualization of data from LSI LASTEM dataloggers. 

Xpanel contains a communicator program (XPanelCommunicator) that receives the data by the 

dataloggers or by the program CommNetEG and transmits them over the network using TCP 

connection, and a viewer (XPanelViewer) that displays the received data with different types of 

indicators. 
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To use CommNetEG as a source for XPanel you must add at least one Data Storage Groups for 

Other Data selecting the data storage XPanelFile. 

 

The configuration form shows only the predefined folder when the instantaneous data will be saved: 

 

 
 

 

ATTENTION 

Carefully read the XPanel user guide for more information about the use of CommNetEG as a 

source for XPanelCommunicator. 

 

5.7. Configuration of instruments groups  
 

 

An Instrument Group is an aggregation of instruments that uses a particular call and saves the data 

in a particular group of data storage. For example instruments called every 30 minutes, which save 

the data processed in the database Gidas. 

 

In order to configure a Instrument Group select it from navigator; to create a new one select menu  

Edit -> Add Group. 
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For every Group it’s possible to specify: 

 

 ID name of the group; 

 Description of the group; 

 The group of data storage for elaborated data; 

 The group of data storage for not elaborated data; 

 The list of the instruments put into the group. 

 

Furthermore it’s possible to disable the Group selecting checkbox Enabled: in this case the group 

will not be used during the running of CommNetEG.  

 

The data of group’s instruments (downloaded according to modes of call to which the group is 

associated) will be saved into data storage suited for required datum type. Use key  to add one 

data storage and the key  to remove it. 

 

Use keys <Add> e <Remove> to add or remove one instrument from the list. 

Use keys  to modify the sequence of the instruments: the sequence of the instruments 

list is the same sequence followed by CommNetEG program when it calls the instruments. 

 

WARNING 

One instrument can belong to different groups only if they use the same elaborated data storage 

group; this condition is required because the date of data request is added to each call that 

requires the elaborated data of one instrument. Without this limitation, if and instrument belongs 

to different groups (which save on different data storages and are managed by different calls 

made at different times) the data on two data storages will be incomplete. 

 

5.7.1. Available instruments window  
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Select key <Add> to add a instrument to Group: it’ll be displayed the window of Available 

instruments. 

 

 
 

This window shows all available instruments and specify the type, the serial number and firmware 

version, the description and the state. The keys under headline bar allow: 

 

  to modify the communication parameters of the selected instrument;  

  to display the personal data of the selected instrument; 

  to display the instantaneous data of the selected instrument; 

  to display the state of the selected instrument. 

 

To add one or more instruments to the list of Instrument Group select the instrument (or the 

instruments) and press key <Add>. 

 

You can get to this windows also through menu Tools -> Available Instruments (in this case there 

isn’t key <Add>). 

 

WARNING 

In order to modify or download the instrument’s configuration use program 3DOM; the 

instruments marked with exclamation mark cannot be used until their current configuration has 

been received through 3DOM. 

 

3DOM software, with current configuration of instrument, must be installed on PC that uses 

CommNetEG in order to download data. Otherwise the configuration must be exported and then 

imported on PC that uses CommNetEG . 

After modify of the configuration and the re-establishment of software function, these operation 

should be execute: 

- “Disable communications” from Edit menu, 

- “Reload current configuration” from File menu, 
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- “Enable communications” from Edit menu. 

 

 

5.8. Calls configuration 
 

There are two typologies of calls: 

 

 Outgoing calls: the program executes the programmed calls towards the instrument 

according to schedule fixed by the user; 

 Incoming calls: the instrument executes the incoming calls according to configuration’s 

setups; for example the GPRS calls. 

 

To configure one Call select it from browser; to set up a new programmed call select menu Edit -> 

Add Call or menu Add new on the item browser’s Outgoing Calls; to set-up a new entry call select 

menu Add new on the item browser’s Incoming Calls. 

Input the name of the call and then modify other parameters. The configuration panel of the call 

consists of two sections: Communication e Schedule. 

 

5.8.1. Outgoing Calls 

 

The section Communication allows to specify the typology of data required by the instrument, or 

commands to enter (clock synchronization, power off communication device); it’s possible to select 

several communication typologies at the same time; they’ll be managed together in the same call. 

 

 

 
 

It’s possible to select one or more communication types; they are:  

 

 Instantaneous Data: they represent last value acquired by each measure; the value is 

updated inside the instrument according to acquisition rate programmed for every measure; 

the request to transfer these data doesn’t start again their acquisition by the instrument; 
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 Elaborated Data: they represent the whole statistic data calculated for each measure; the 

program receives the elaborated data (of all measures) from previous reception date to last 

available datum; in this way computer’s updated all processed data stored into the 

instrument, whenever using shortest time (§ 6.4). 

 Statistics: they represent the statistic information calculated according to instrument 

operation; these data can be used to execute diagnostic computer side facilities; 

 Clock synchronization: it sets instrument’s hour according to PC’s hour; it’s important that 

PC has been synchronised correctly, i.e. using synchronization system from NTP server; it’s 

useful synchronize the instruments’ clocks in case they manage the timed starting of the 

communication equipments, allowing to CommNetEG to execute the communication at 

provided time; an other reason is to obtain elaborated data compatible among different 

instruments perfectly; the clock synchronization should happen once a day at least; it isn’t 

useful to synchronize the clock for periods shorter than one hour; the synchronization hours 

is selected according to program configuration (§ 5.12); 

 Power off communication device: it switches off automatically the communication 

equipment (modem, radio, protocol converter) connected to the instrument and lined up 

through actuator n. 7; this is an useful function to reduce the acquisition system 

consumption at least (it’s often more conditioned by the communication equipment); the 

switch-off happens 60 seconds after the reception of switch-off command and owing to 

inactivity of further communications; in case the communication equipment is power on 

through timer actuator it’s recommended the instrument synchronization through command 

Clock synchronization. 

 

The section Schedule determines when the instrument is called, through setup of following 

parameters: 

 

 Call modes; 

 Call timing (starting hour, end hours, interval, day of the week); 

 The delay (in seconds) of call execution as regard provided hour; 

 The maximum number of call queues that happen in case the communication equipment 

fails the connection to the instrument; the current call is queued to calls already present for 

device in question. 
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The call mode may be Repeated or One shot. In case of call Repeated specify: 

 

 Starting hour; 

 End hour; 

 Interval between two calls; 

 Days of the week in which execute the call. 

 

If call is One shot it’s necessary to specify the hour of call: in this case the call will be carried out 

only once at specified hour every day among selected days. 

 

At the end specify the groups of instruments that take part to the call; if several instruments use 

same communication device at the same time, the program will queue and get over them one at a 

time. To add or remove a Group (of Instruments) from list use keys <Add> e <Remove>. 

 

Furthermore it’s possible to disable the Call deselecting the checkbox Enabled: in this case the call 

won’t be used during execution of CommNetEG, but remain configured all the same for future re-

use. 
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5.8.2. Incoming Calls 

 

The Communication section and the list of the Instruments Groups are configured in the same way 

of the Outgoing Calls. 

 

The Schedule section considers only the configuration of one slot. When the program receives one 

incoming call it checks the incoming calls associated to the instrument, which have call slot that 

includes current time. So for that call are executed the types of communication it programmed in. 

 

 

5.9. Guided Procedure for configuration of one 

instruments group 
 

It’s possible set-up one new configuration setting its items in the following order: 

1. configuration data storage groups (§ 5.6); 

2. configuration of instrument groups (§ 5.7); 

3. configuration of calls (§ 5.8). 

 

Alternatively it’s possible activate the guided procedure for configuration of one instruments group. 

to activate the guided procedure select menu Edit->Add Instruments Group Configuration or select 

key  . 

 

Step 1: Instruments add: 

 

 
 

Input the name of the group and its description.  

To add or remove one instrument from the list use keys <Add> e <Remove>. 

To modify the order of the instruments use keys : the list of instruments has the same 

order the instruments are called by CommNetEG program with. 
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Step 2: selection of call type: 

 

 
 

Select the type of call associated to the group (§ 5.8) 

 

Step 3: Calls configuration 

 
 

Use keys <Add>, <Edit> e <Remove> in order to configure the calls associated to this instruments 

group. The call configuration determines the type of required data and the call’s time modes for 

outgoing calls (§ 5.8). 

 

Step 4: Configuration options for storage of elaborated data 
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If call considers the storage of elaborated data you have to specify the data storages for save of 

elaborated data. Through this screen you can select one storage group already associated to 

configuration or add a new one. Use keys <Add>, <Edit> e <Remove> to add, modify or remove 

items that you want associate to new data storage group for processed data. 

 

Step 5: Configuration options for storage of instantaneous data 

 

 
 

If call considers the storage of instantaneous data you have to specify the data storages for save of 

instantaneous data. Through this screen you can select one storage group already associated to 

configuration or add a new one. Use keys <Add>, <Edit> e <Remove> to add, modify or remove 

items that you want associate to new data storage group for instantaneous data. 

 

Going on to next step the information collection will be complete and you’ll be able to generate the 

configuration: the items inputted during guided procedure will be added to current configuration. 

 

5.10. Instruments Views Configuration 
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The Instruments Views are a way to aggregate the instruments to facilitate the visualization of the 

state of communications and of the data saved in the communication program CommNetEG. For 

example, you can aggregate in a view instruments of the same type, or belonging to a single 

customer, or sited in the same geographical area. Conversely Groups (§ 5.7) aggregate instruments 

according to the characteristics of the calls. 

 

To configure Instrument Views select the node on the Browser: 

 

 
 

By default the program uses the Groups as Views. To create customized views deselect the option 

Use Instruments Groups as Views. Initially, all the instruments are located in the root node 

Instruments Views. 

 

 To add a new View select the button AddView; 

 To rename or remove a View use the contextual menu by right clicking on the view node; if 

you remove a View all the instruments of the View are moved under the root node 

Instruments Views. 

 To move an instruments from a View to another simply drag it into the new View. 
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The program CommNetEG allows you to select the instruments to be displayed in the information 

panel in accordance with the views defined in the configuration; you can also select to display all 

the instruments. 

 

The instruments that are not associated with a View that will remain in the Views root node: in i 

program these instruments will be visible only if you select the option to display all the instruments. 

 

5.11. Check and save of the configuration 
 

When one configuration is loaded or saved or when menu File -> Verify is selected, the program 

verifies the consistence of contained data. If configuration has some problems, it shows one 

Messages list that contains all signals about the consistence check. 

 

 
 

The list of messages can shows error messages and warning messages: in case there are only 

warning messages and the save of configuration has been required it shows key <Continue> that 

allows the execution of the save. 

 

 

5.12. Name of the configuration and clocks 

synchronization options  
 

In order to modify the name of configuration and clocks synchronization options select the main 

node of browser. 
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In this panel it’s possible to modify the name of configuration (displayed in the main element of 

browser) and the synchronization modes of instrument’s clock. 

 

5.13. Display of Configuration Card 
 

Through menu File  Show report…  you can display card of current configuration in text format; 

it shows, for each instrument, the call modes, the required data and the data storages where required 

data are saved. 

 

 
 

 

 

5.14. Modification of processed data request date 
 

When you ask the instrument for elaborated data, at the end of downloaded data storage, the system 

stores the date of last saved datum in order to set-up the date of next request automatically. If data 

are stored in several storage mediums, it’s used oldest date (about mediums’ errors make reference 

to  (§ 6.4). If elaborated data have never been downloaded, the program asks the instruments for all 

its data.  

 

Through menu Edit  Edit elaborated data date request you can modify the request date of 

processed data of each configured instrument: the modified date will be used at next call by 

CommNetEG. 

 

The modification window displays the date that will be used for request of processed data at next 

call by CommNetEG too. 
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5.15. Import and Export of configurations into 

other computers 
 

When you need to move the execution of CommNetEG on an other computer, besides installing the 

needed programs, may be useful transfer current configuration, but it ISN’T enough to copy file 

which includes it. CommNetEG configuration needs other files in order to operate correctly. For 

each instrument it needs: 

 

 File that includes the description of instrument type and of its release; 

 Files that include the configuration of measures; 

 File that includes the calibration; 

 File that includes the configuration of communication’s parameters; 

 Licence file; 

 File that includes the date of last datum saved in storage mediums. 

 

Use menu Tools   Export Configuration to export one configuration; this menu activates the 

guided procedure that sets-up one new file (zip file); this file includes all files needed to repeat 

configuration on other  computer. 

 

Use menu Tools  Import Configuration to import one configuration; this menu activates the 

guided procedure that copies all files needed for operation of configuration in a new computer 

(beginning from zip file set-up through export procedure). 

 

ATTENTION 

CommNetEG software must be disactived during both operations of Export configuration and 

Import configuration 
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6. CommNetEG 
 

The program CommNetEG executes communications in automatic or manual mode with 

instruments of series E-Log and storages the received data on different data storage. 

 

The operation modes of the program are contained inside the configuration files generated by the 

program CommNetEG Config described in previous chapter. 

 

 

6.1. Program’s main parts 
This is the program after its start: 

 

 
 

 

The area Devices shows: 

 

 Program’s operation state; 

 List of configured communication devices; for each device it shows: 

o Operation state of the device; 

o Type of current communication (request of instantaneous data, elaborated data, …); 

o The finishing percentage of communications estimated for call in progress;  

o The instrument that is communicating on the device; 

o The date of the last communication; 

o The date of last error recorded on the device; 

o The instruments connected to device: the connection leads to a window that shows 

all configured instruments which communicate with specified device.  

 

 

In case of incoming call (for example when instrument communicates through GPRS) the program 

sets-up device’s line just at time of first received call: if in configuration’s file has been set-up 

HideIncomingDisconnectedConnection=true, the set-up device’s line is cancelled at the end of 

communication [§ 6.9]. Furthermore link referred to instruments connected to device is always 

empty. 
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The area Instruments shows: 

 

 The number of data storage requests (that are waiting to be executed) on several storage 

devices; 

 The instruments Views list; 

 The list of configured instruments; for each instrument it shows: 

o The serial number;  

o The description; 

o The presence of a running connection; 

o The instrument state; 

o The date of last communication;  

o The date of last elaborated stored datum;  

o The delay of the last elaborated value; 

o The date of last error stored in data save. 

 

 

 

6.2. Menus structure 
 

By means of menu and keys bar you can select the program’s options. 

 

The menu File shows: 

 

 Open: opens an exiting configuration and loads it; 

 Recent files: opens a configuration recently opened and loads it; 

 Reload Current configuration: it reloads current configuration; the command is available 

only after the communications with the instruments have been disabled. 

 Exit: closes the program. 

 

The menu Run shows: 

 

 Enable Communications: starts the timing of outgoing calls and the reception of incoming 

calls; 

 Disable Communications: stops the timing of outgoing calls and the reception of incoming 

calls, awaiting for the end of calls in progress; 

 Abort Communication: stops the communications but doesn’t await for the end of 

communications in progress and stops the calls’ scheduler and the reception of incoming 

calls 

 Clear date queue: it empties the list of not saved data, without saving them. 

 

The menu Tools shows: 

 

 Manual Call: displays the window for manual calls; 

 Show Running Events: displays a window that shows log messages generated by the 

application running; 

 Explore Events File: display a windows that allows to explore log file content, using various 

kind of filters: 

 Show Statistics: displays the communication’s statistics; 

 Edit Actual Configuration: starts program CommNetEG Config and initializes it with current 

configuration; 

 Show Configuration State: checks the configuration in progress and displays its possible 

fault messages. 
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 Set Auto Start : sets the program to start automatically when the P.C starts; 

 Remove Auto Start: remove auto start option; 

 Edit Program Settings: display a windows that allows the edit of the settings of the program. 

 

The menu Help shows: 

 

 Contents: displays this document; 

 Check for Updates: checks possible program’s updates from LSI Lastem web site; 

 About this Application...: shows the information about application, version included. 

 

 

 

6.3. Program starting 
 

At CommNetEG program starting it loads last configuration used during previous execution, and so 

starts communications automatically. 

 

6.3.1. Configuration replacement 

 

Change configuration as follow: 

 

1. Stop communication by menu Run  Disable Communications; 

2. Load new configuration by menu File  Open; 

3. Start communications by menu Run  Enable Communications. 

 

If loaded configuration has got some problems, the program doesn’t start; if configuration has got 

notice messages (i.e. contradictions or abnormal conditions which anyway allow its operation), the 

program starts but its status bar signals these notices: 

 

 
 

Click on status bar or select menu Tools  Show Configuration State  to display notice messages 

list: 
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Consider that all items that aren’t used by the configuration (groups or disabled calls, instruments 

included into disabled calls…) are excluded from every program’s actions. 

6.3.2. Display /Modification of current configuration 

 

Select menu Tools  Edit actual Configuration  to display current configuration. This  menu starts 

the configuration program through current configuration. If the configuration program has already 

been started, close it and repeat same operation, or check that active instance is using same 

configuration file like CommNetEG and, at the opposite, open file with current configuration. 

 

In order to modify current configuration you have to stop timing of exit calls and the reception of 

entry calls (menu Run  Disable Communications), then reload the configuration through menu 

File  Reload Current Configuration or through icon in the toolbar. 

 

 

6.4. Management of elaborated data storage  
 

The program tries to save the data received from the instruments on all data storage of elaborated 

data configured for each specific instrument. 

 

In case of no storage errors, the programs updates the date for next request of elaborated data 

according to date of the latest value saved on several data storage: in this way at next call it’ll be 

required only data later than saved data. 

  

In case one data storage isn’t able to save the data correctly, the program doesn’t update the request 

date of elaborated data. It may happen in case the connection to database or to network has been 

broken off. Through this operation mode (if data storage has been reconnected) all data storage will 

be updated with all data received from the instrument. If the lack of connection lasts, the instrument 

will require much more data: the program is able to manage the communication’s timeout during 

data download saving the data partially downloaded. 

 

It’s possible to modify this operation mode (§ 6.10) 

 

 

 

6.5. Viewing the status of communications and 

data storage 
 

The program displays the status of the communication channels and the status of the individual 

instruments on two separate lists. 
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If an error occurs while communicating or while storing data the error is indicated by a special icon 

 with the date / time of the error, which is useful to check the recorded events (§ 6.6) to 

investigate the cause of the problem. If the next communication or data storage occurs without error 

the error message is removed. You can change this setting (§ ) to maintain track of the error: in this 

case the error icon is replaced by a warning icon . 

 

It is possible to delete error message by right clicking on a device or on an instrument using the 

contextual menu: 

 

 
 

If you right click on another place of the list you can delete all the error messages. 

 

The status of individual instruments reports the result of the last communication and elaborated data 

storage. Useful indication is represented by the last two columns Last stored elaboration date  and 

Delay. These columns show, respectively, the date of the last saved elaborated data, which 

corresponds to the date of requesting data for subsequent communication, and the delay with 

respect to the current date chosen on the basis  of the clock synchronization options (local time, 

solar time, UTC §5.12); the delay is helpful in evaluating the communication status of the 

instrument. 

6.5.1. Using Instruments Views 

It is possible to filter instruments on the list using the Instrument Views defined in the configuration 

(§ 5.10). To change the filter select another View from the list Select View. 

 

6.6. Events display 
 

Select menu Tools  Show Running Events to display the (log) event messages generated by the 

application. This menu displays a window which includes last event messages generated by the 

program: 
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Select Clear to clean the list; selecting Open the program starts Window explorer and seeks it on the 

folder where is included the file that includes the log’s program. 

 

To stop the automatic update of the event messages deselect the folder Show event messages 

continuously. 

 

The events recording file lies default in: 

 

C:\Documents and Settings\[User]\Application Data\LSI-Lastem\CommNetEG\Log 

 

where [user] represents the current Windows user. 

 

The default setups creates a log file every day and its name is [year]-[mouth]-[day].txt. 

Every line of log file consists of following information: 

 

 Date: format yyyy-mm-dd; 

 Hour: format hh:mm:ss:ms; 

 Thread: name or number of thread that has generated the event; 

 Event type: INFO (standard operations), WARNING, ERROR (operation errors found by 

the program) and DEBUG (can be set up only by LSI LASTEM); 

 Procedure: procedure that has generated the log message; 

 Event description. 

 

 
 

 

6.6.1. Examination and research in the files of events 

Select menu Tools  Explore Events File to display the window which allows user to explore the 

content of log files using different kind of filter. 
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In this form you can: 

 Select the log file to examine (log file are stored on a daily base); 

 Filter message using Log Level; 

 Add text filter in AND or OR mode (for example using serial number of an instrument); 

 Select messages starting from a user defined date (in the day of the log file). 

 

selecting Open Log Folder the program starts Window explorer and seeks it on the folder where is 

included the file that includes the log’s program. 

 

 

6.7. Manual data request  
 

Even if automatic calls have been set up, it’s possible to execute a manual call selecting menu Tools 

 Manual Call. 

 

To run the manual call of an instrument follow these instructions: 

 The communications must be enabled; 

 The instrument must belong to a valid programmed call. 

 

This is the window for manage of manual calls:  
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The section Call properties allows the setup of:  

 

 Types of data that have to be required; 

 Request date for elaborated data; two options are available:  

o It uses automatically for each instrument the date of last saved elaborated datum; 

o It sets up an exact date valid for all selected instruments. 

 

The section Instruments/Groups sets up the instruments or the groups that user needs to put into the 

manual call; the list shows the instruments or the groups according to selected key Show 

Instruments or Show Group. 

 

In the display Instrument (like shown in the figure) the list displays: the serial number and all files 

for processed data and for other types of data connected to the instrument; in groups display the list 

displays only the name of the group and its description. 

 

WARNING 

The manual call always manages on single instruments: set up the selection on groups only in 

order to select contemporary all instruments that belong to selected group. 

 

Remember: the instruments are included into groups and every group is connected to a storage 

group for elaborated data and to a storage group for non-elaborated data; every storage group can 

contain the configuration of different data storage of available ones. 

 

After setup of the call modes and after selection of elements or groups press key Enqueue to start 

the manual call; this action queues the call into the execution’s queue of CommNetEG. If checkbox 

Priority respect already waiting calls has been selected, the call is queued giving it priority over the 

calls included into the queue, otherwise it doesn’t happen. 

After press the key Enqueue the window shows the list Results that indicates if the communication 

has been a good result. 

 

WARNING 

If user selects instruments that haven’t been configured to save a certain type of data and the call 

requires them, data like that won’t be saved. 
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If user uses selection mode through groups, the program sets up the list of all instruments that 

belong to single groups rejecting possible doubles (every instrument can belong to several 

groups) and the data required by the call will be saved on all data storage configured for single 

instrument and not only on data storage configured for the selected group: for this reason the 

selection list in mode Groups doesn’t shows the configured data storage. 

 

6.8. Change the date of the data request 
 

When the program calls an instrument to get elaborated data it requires all the data contained in the 

instrument only at the first communication while for subsequent communication it uses the date of 

the last elaborated data stored correctly. 

 

It is possible to change the date of the request by right clicking on the instrument and selecting the 

Change Date to Request Data menu. 

 

 
 

WARNING 

Don’t change the date of the request while the instrument is communicating with the program. 

 

6.9. Statistics Display 
 

Select menu Instrument  Show Statistics  to display the communication statistics. 

 

 
 

The communication statistics window displays following information for each instrument: 

 

 Number of total connections, failed connections and connections executed but ended with 

error; 

 Duration of last connection; 

 Total duration of connections; 

 Total entering frames (data packet) and damaged frames; 

 Number of exiting frames; 

 Total exiting bytes and entering bytes. 
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First line of window displays the total statistics. 

 

In this window there are following actions:: 

 

 Contextual menu resets the statistics of selected item on one line of table Reset selected; 

 Key Reset resets all statistics; 

 Key Remove starts window for removal of statistics items. 

 

Take into consideration that if you change configuration or modify the instruments managed by 

CommNetEG, the statistics of not managed instruments are always displayed (even if obviously the 

values don’t change): to remove not used items press key Remove. 

 

The removal window displays all existing items and allows their removal. If you remove the 

statistic of a managed instrument, the statistic item will be set-up at first communication. 

 

 

6.10. Configuration files of program operation 
 

Select Tools  Edit Program Settings to show the window to edit program’s settings. 
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Options that require a restart of the program 

 Hide warning configuration messages when the program start preventing dialog box to 

appear: Select this option if the program is set to start automatically, or if the configuration 

has warning messages the messages are displayed and the program waits for a response from 

the user. 

 

Options that apply after reloading configuration 

 Update the date of the request of the data if at least one storage medium save the data: if it’s 

not been selected and just one data storage of processed data fails the save, it doesn’t update 

the request date of processed data. 

 Maximum amount of data in bytes downloaded during a call: indicates the maximum 

amount of data in bytes downloaded during a call; this parameter is to avoid expensive calls. 

If for some reason the program fails to download multiple times the data of an instrument it 

can happen that the size of stored data  (and thus required during download) exceeds the 

value of this parameter. In this case, the program will NOT download the data. Manually 

increase this value, download data and then restore it. 

 

 

Options that apply after pressing the button <Ok> 

 Delete the line created by an entry call in the devices list control at the end of the 

connection: if selected the program deletes the line created during storage of an entry call 

from the list of devices at the end of connection. 

 Allow to close the program even if there are communications in progress, automatically 

interrupting them: if selected it is possible to close the program even if there are 

communications in progress, automatically interrupting them. 

 Keep error flag even after a successfully communication with the instrument: if selected 

keep trace of previous error messages even if the last communication/data storage was 

successfully; 

 Maximum number of messages displayed in the message window: sets up max number of 

messages displayed by events window; 

 Second to wait the refresh of the delay column: amount of seconds to wait the refresh of the 

delay information; 

 Minutes over which  the delay of the processed data is displayed in red: minutes over which 

the delay of the elaborated data storage is shown in red; 

 Second to wait when user stop communications before aborting those in progress: when the 

communications are interrupted the program attends the closing of those in progress. After 

this interval of time in seconds the user can however abort the communications in progress. 


